q

News from Habari

Habari 0.9.2 released

Q

We've released Habari 0.9.2, which contains security and bug fixes, and enhancements for the 0.9 series. All users of Habari 0.9 and 0.9.1 are encouraged to upgrade.
A couple of things to note:

  • PHP version 5.3 is no longer supported by the PHP group, and it is also not supported by Habari. PHP 5.4 is now required.
  • There are several bug fixes and two important security fixes in this release. We fixed access to unpublished posts and closed a security leak where users were able to modify other accounts. An attacker would need to have an account on your site, know the internal ID of another user and modify formula data. Still we consider this a severe risk and highly recommend upgrading immediately.

For details, read the complete release notes. Upgrades from 0.9 and 0.9.1 should be safe but of course backing up is always a good idea. If you're upgrading from an earlier version make sure to see the upgrade instructions.

You can download Habari 0.9.2 or use git to clone it from our repo on Github.